docker.io/grafana/grafana

main-ubuntulinux-amd64sha256:979eb8e70a6453ed5a0010643ec087137878ba6a602de903390b234c7de09787

Vulnerabilities

605132

Packages

54585

Fingerprint

Unavailable

Vulnerability Breakdown

Critical

High

Medium

Low

Negligible

0

0

22

35

3

Compared with

Packages

  • 6 packages updated
  • 113 packages added
  • 28 packages removed

Change in vulnerabilities

  • -2 critical
  • -4 high
  • -1 medium
  • 25 low
  • 3 negligible
  • -2 unknown

All Packages

Name
Version
Language
License
Vulnerabilities
Vulnerability breakdown
./pkg/util/xorm(devel)go0
@grafana-plugins/grafana-azure-monitor-datasource11.2.0-185284javascript0
@grafana-plugins/grafana-postgresql-datasource11.2.0-185284javascript0
@grafana-plugins/grafana-pyroscope-datasource11.2.0-185284javascript0
@grafana-plugins/grafana-testdata-datasource11.2.0-185284javascript0
@grafana-plugins/jaeger11.2.0-185284javascript0
@grafana-plugins/mysql11.2.0-185284javascript0
@grafana-plugins/parca11.2.0-185284javascript0
@grafana-plugins/stackdriver11.2.0-185284javascript0
@grafana-plugins/tempo11.2.0-185284javascript0
@grafana-plugins/zipkin11.2.0-185284javascript0
adduser3.118ubuntu5GPL-20
apt2.4.12GPL-2, GPLv2+0
base-files12ubuntu4.6GPL0
base-passwd3.5.52build1GPL-2, public-domain0
bash5.1-6ubuntu1.1GPL-30

All Vulnerabilities

Package
Version
CVE
Severity
Fixed in
github.com/Azure/azure-sdk-for-go/sdk/azidentityv1.5.2GHSA-m5vv-6r4h-3vj9
medium
1.6.0
libssl33.0.2-0ubuntu1.15CVE-2022-40735
medium
3.0.2-0ubuntu1.16
libsystemd0249.11-0ubuntu3.12CVE-2023-7008
medium
0:239-82.el8
libudev1249.11-0ubuntu3.12CVE-2023-7008
medium
0:239-82.el8
libgssapi-krb5-21.19.2-2ubuntu0.3CVE-2024-26462
medium
libgssapi-krb5-21.19.2-2ubuntu0.3CVE-2024-37370
medium
libgssapi-krb5-21.19.2-2ubuntu0.3CVE-2024-37371
medium
libk5crypto31.19.2-2ubuntu0.3CVE-2024-26462
medium
libk5crypto31.19.2-2ubuntu0.3CVE-2024-37370
medium
libk5crypto31.19.2-2ubuntu0.3CVE-2024-37371
medium
libkrb5-31.19.2-2ubuntu0.3CVE-2024-26462
medium
libkrb5-31.19.2-2ubuntu0.3CVE-2024-37370
medium
libkrb5-31.19.2-2ubuntu0.3CVE-2024-37371
medium
libkrb5support01.19.2-2ubuntu0.3CVE-2024-26462
medium
libkrb5support01.19.2-2ubuntu0.3CVE-2024-37370
medium
libkrb5support01.19.2-2ubuntu0.3CVE-2024-37371
medium

Compared with

Changes in vulnerabilities

diff
CVE
Severity
Fixed in
CVE-2023-4039
medium
CVE-2023-4039
medium
CVE-2024-2236
medium
CVE-2024-26462
medium
CVE-2024-37370
medium
CVE-2024-37371
medium
CVE-2024-26462
medium
CVE-2024-37370
medium
CVE-2024-37371
medium
CVE-2024-26462
medium
CVE-2024-37370
medium
CVE-2024-37371
medium
CVE-2024-26462
medium
CVE-2024-37370
medium
CVE-2024-37371
medium
CVE-2020-22916
medium
CVE-2022-40735
medium
3.0.2-0ubuntu1.16
CVE-2023-4039
medium
CVE-2023-7008
medium
0:239-82.el8
CVE-2021-46848
medium
0:4.13-4.el8_7
CVE-2023-7008
medium
0:239-82.el8
CVE-2016-2781
low
CVE-2022-27943
low
CVE-2022-3219
low
CVE-2022-27943
low
CVE-2024-26458
low
0:1.18.2-27.el8_10
CVE-2024-26461
low
0:1.18.2-27.el8_10
CVE-2024-26458
low
0:1.18.2-27.el8_10
CVE-2024-26461
low
0:1.18.2-27.el8_10
CVE-2024-26458
low
0:1.18.2-27.el8_10
CVE-2024-26461
low
0:1.18.2-27.el8_10
CVE-2024-26458
low
0:1.18.2-27.el8_10
CVE-2024-26461
low
0:1.18.2-27.el8_10
CVE-2023-45918
low
CVE-2023-50495
low
CVE-2023-45918
low
CVE-2023-50495
low
CVE-2022-41409
low
CVE-2022-27943
low
CVE-2023-45918
low
CVE-2023-50495
low
CVE-2022-4899
low
CVE-2023-29383
low
CVE-2023-45918
low
CVE-2023-50495
low
CVE-2023-45918
low
CVE-2023-50495
low
CVE-2023-29383
low
CVE-2016-20013
negligible
CVE-2016-20013
negligible
CVE-2017-11164
negligible
CVE-2019-1010022
critical
CVE-2023-0687
critical
CVE-2019-1010023
high
CVE-2023-4911
high
0:2.28-225.el8_8.6
CVE-2024-2961
high
0:2.28-251.el8_10.1
CVE-2024-33599
high
0:2.28-251.el8_10.2
CVE-2023-42363
medium
1.36.1-r7
CVE-2023-42364
medium
1.36.1-r7
CVE-2023-42365
medium
1.36.1-r7
CVE-2023-42366
medium
1.36.1-r6
CVE-2023-42363
medium
1.36.1-r7
CVE-2023-42364
medium
1.36.1-r7
CVE-2023-42365
medium
1.36.1-r7
CVE-2023-42366
medium
1.36.1-r6
CVE-2024-0853
medium
CVE-2024-2398
medium
CVE-2010-4756
medium
CVE-2019-1010024
medium
CVE-2019-1010025
medium
CVE-2023-4527
medium
0:2.28-225.el8_8.6
CVE-2023-4813
medium
0:2.28-225.el8_8.6
CVE-2023-5156
medium
2.35-0ubuntu3.5
CVE-2024-33600
medium
0:2.28-251.el8_10.2
CVE-2024-28182
medium
CVE-2023-42363
medium
1.36.1-r7
CVE-2023-42364
medium
1.36.1-r7
CVE-2023-42365
medium
1.36.1-r7
CVE-2023-42366
medium
1.36.1-r6
CVE-2024-33601
low
0:2.28-251.el8_10.2
CVE-2024-33602
low
0:2.28-251.el8_10.2
CVE-2024-2004
unknown
CVE-2024-2466
unknown

Changes in packages

diff
Name
Version
Language
License
adduser3.118ubuntu5GPL-2
alpine-baselayout3.4.3-r2GPL-2.0-only
alpine-baselayout-data3.4.3-r2GPL-2.0-only
alpine-keys2.4-r1MIT
apk-tools2.14.0-r5GPL-2.0-only
apt2.4.12GPL-2, GPLv2+
base-files12ubuntu4.6GPL
base-passwd3.5.52build1GPL-2, public-domain
bash5.2.21-r0GPL-3.0-or-later
bash5.1-6ubuntu1.1GPL-3
bash5.1.16
brotli-libs1.1.0-r1MIT
bsdutils1:2.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
busybox1.36.1-r15GPL-2.0-only
busybox-binsh1.36.1-r15GPL-2.0-only
c-ares1.27.0-r0MIT
ca-certificates20240226-r0MPL-2.0 AND MIT
ca-certificates20230311ubuntu0.22.04.1GPL-2, GPL-2+, MPL-2.0
ca-certificates-bundle20230506-r0MPL-2.0 AND MIT
coreutils8.32-4.1ubuntu1.2GPL-3
curl8.5.0-r0curl
curl7.81.0-1ubuntu1.16BSD-3-Clause, BSD-4-Clause, ISC, curl, other, public-domain
dash0.5.11+git20210903+057cd650a4ed-3build1BSD-3-Clause, BSD-3-clause, Expat, FSFUL, FSFULLR, GPL-2, GPL-2+, public-domain
debconf1.5.79ubuntu1BSD-2-clause
debianutils5.5-1ubuntu2GPL-2
diffutils1:3.8-0ubuntu2GFDL, GPL
dpkg1.21.1ubuntu2.3BSD-2-clause, GPL-2, GPL-2+, public-domain-md5, public-domain-s-s-d
e2fsprogs1.46.5-2ubuntu1.1GPL-2, LGPL-2
findutils4.8.0-1ubuntu3GFDL-1.3, GPL-3
gcc-12-base12.3.0-1ubuntu1~22.04Artistic, GFDL-1.2, GPL, GPL-2, GPL-3, LGPL
gcompat1.1.0-r4NCSA
glibc2.35-r0LGPL
glibc-bin2.35-r0LGPL
gpgv2.2.27-3ubuntu2.1BSD-3-clause, CC0-1.0, Expat, GPL-3, GPL-3+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, RFC-Reference, TinySCHEME, permissive
grep3.7-1build1GPL-3, GPL-3+
gzip1.10-4ubuntu4.1FSF-manpages, GFDL-1.3+-no-invariant, GFDL-3, GPL-3, GPL-3+
hostname3.23ubuntu2GPL-2
init-system-helpers1.62BSD-3-clause, GPL-2, GPL-2+
libacl12.3.1-1GPL-2, GPL-2+, LGPL-2+, LGPL-2.1
libapt-pkg6.02.4.12GPL-2, GPLv2+
libattr11:2.5.1-1build1GPL-2, GPL-2+, LGPL-2+, LGPL-2.1
libaudit11:3.0.7-1build1GPL-1, GPL-2, LGPL-2.1
libaudit-common1:3.0.7-1build1GPL-1, GPL-2, LGPL-2.1
libblkid12.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
libbrotli11.0.9-2build6MIT
libbz2-1.01.0.8-5build1BSD-variant, GPL-2
libc62.35-0ubuntu3.8GFDL-1.3, GPL-2, LGPL-2.1
libc-bin2.35-0ubuntu3.8GFDL-1.3, GPL-2, LGPL-2.1
libc-utils0.7.2-r5BSD-2-Clause AND BSD-3-Clause
libcap21:2.44-1ubuntu0.22.04.1BSD-3-clause, GPL-2, GPL-2+
libcap-ng00.7.9-2.2build3GPL-2, GPL-3, LGPL-2.1
libcom-err21.46.5-2ubuntu1.1
libcrypt11:4.4.27-1
libcrypto33.1.4-r5Apache-2.0
libcurl8.5.0-r0curl
libcurl47.81.0-1ubuntu1.16BSD-3-Clause, BSD-4-Clause, ISC, curl, other, public-domain
libdb5.35.3.28+dfsg1-0.8ubuntu3
libdebconfclient00.261ubuntu1
libext2fs21.46.5-2ubuntu1.1GPL-2, LGPL-2
libffi83.4.2-4GPL
libgcc13.2.1_git20231014-r0GPL-2.0-or-later AND LGPL-2.1-or-later
libgcc-s112.3.0-1ubuntu1~22.04Artistic, GFDL-1.2, GPL, GPL-2, GPL-3, LGPL
libgcrypt201.9.4-3ubuntu3GPL-2, LGPL
libgmp102:6.2.1+dfsg-3ubuntu1GPL, GPL-2, GPL-3, LGPL-3
libgnutls303.7.3-4ubuntu1.5Apache-2.0, BSD-3-Clause, CC0, Expat, GFDL-1.3, GPL, GPL-3, GPLv3+, LGPL, LGPL-3, LGPLv2.1+, LGPLv3+_or_GPLv2+, The
libgpg-error01.43-3BSD-3-clause, GPL-3, GPL-3+, LGPL-2.1, LGPL-2.1+, g10-permissive
libgssapi-krb5-21.19.2-2ubuntu0.3GPL-2
libhogweed63.7.3-1build2Expat, GAP, GPL, GPL-2, GPL-2+, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-3+, public-domain
libidn22.3.4-r4GPL-2.0-or-later OR LGPL-3.0-or-later
libidn2-02.3.2-2build1GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL-3, LGPL-3+, Unicode
libk5crypto31.19.2-2ubuntu0.3GPL-2
libkeyutils11.6.1-2ubuntu3GPL-2, GPL-2+, LGPL-2, LGPL-2+
libkrb5-31.19.2-2ubuntu0.3GPL-2
libkrb5support01.19.2-2ubuntu0.3GPL-2
libldap-2.5-02.5.17+dfsg-0ubuntu0.22.04.1
libldap-common2.5.17+dfsg-0ubuntu0.22.04.1
liblz4-11.9.3-2build2BSD-2-clause, GPL-2, GPL-2+
liblzma55.2.5-2ubuntu1Autoconf, GPL-2, GPL-2+, GPL-3, LGPL-2, LGPL-2.1, LGPL-2.1+, PD, PD-debian, config-h, noderivs, permissive-fsf, permissive-nowarranty, probably-PD
libmount12.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
libncurses66.3-2ubuntu0.1BSD-3-clause, MIT/X11, X11
libncursesw6.4_p20231125-r0X11
libncursesw66.3-2ubuntu0.1BSD-3-clause, MIT/X11, X11
libnettle83.7.3-1build2Expat, GAP, GPL, GPL-2, GPL-2+, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-3+, public-domain
libnghttp2-141.43.0-1ubuntu0.2BSD-2-clause, Expat, GPL-3, GPL-3+, MIT, SIL-OFL-1.1, all-permissive
libnsl21.3.0-2build2BSD-3-clause, GPL-2, GPL-2+-autoconf-exception, GPL-2+-libtool-exception, GPL-3, GPL-3+-autoconf-exception, LGPL-2.1, LGPL-2.1+, MIT, permissive-autoconf-m4, permissive-autoconf-m4-no-warranty, permissive-configure, permissive-fsf, permissive-makefile-in
libp11-kit00.24.0-6build1Apache-2.0, BSD-3-Clause, ISC, ISC+IBM, LGPL-2.1, LGPL-2.1+, permissive-like-automake-output, same-as-rest-of-p11kit
libpam0g1.4.0-11ubuntu2.4GPL
libpam-modules1.4.0-11ubuntu2.4GPL
libpam-modules-bin1.4.0-11ubuntu2.4GPL
libpam-runtime1.4.0-11ubuntu2.4GPL
libpcre2-8-010.39-3ubuntu0.1
libpcre32:8.39-13ubuntu0.22.04.1
libprocps82:3.3.17-6ubuntu2.1GPL-2, GPL-2.0+, LGPL-2, LGPL-2.0+, LGPL-2.1, LGPL-2.1+
libpsl50.21.0-1.2build2Chromium, MIT
librtmp12.4+20151223.gitfa8646d.1-2build4GPL-2, LGPL-2.1
libsasl2-22.1.27+dfsg2-3ubuntu1.2BSD-2-clause, BSD-2.2-clause, BSD-3-clause, BSD-3-clause-JANET, BSD-3-clause-PADL, BSD-4-clause, BSD-4-clause-UC, FSFULLR, GPL-3, GPL-3+, IBM-as-is, MIT-CMU, MIT-Export, MIT-OpenVision, OpenLDAP, OpenSSL, RSA-MD, SSLeay
libsasl2-modules2.1.27+dfsg2-3ubuntu1.2BSD-2-clause, BSD-2.2-clause, BSD-3-clause, BSD-3-clause-JANET, BSD-3-clause-PADL, BSD-4-clause, BSD-4-clause-UC, FSFULLR, GPL-3, GPL-3+, IBM-as-is, MIT-CMU, MIT-Export, MIT-OpenVision, OpenLDAP, OpenSSL, RSA-MD, SSLeay
libsasl2-modules-db2.1.27+dfsg2-3ubuntu1.2BSD-2-clause, BSD-2.2-clause, BSD-3-clause, BSD-3-clause-JANET, BSD-3-clause-PADL, BSD-4-clause, BSD-4-clause-UC, FSFULLR, GPL-3, GPL-3+, IBM-as-is, MIT-CMU, MIT-Export, MIT-OpenVision, OpenLDAP, OpenSSL, RSA-MD, SSLeay
libseccomp22.5.3-2ubuntu2LGPL-2.1
libselinux13.3-1build2GPL-2, LGPL-2.1
libsemanage23.3-1build2GPL, LGPL
libsemanage-common3.3-1build2GPL, LGPL
libsepol23.3-1build1GPL, LGPL
libsmartcols12.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
libss21.46.5-2ubuntu1.1
libssh-40.9.6-2ubuntu0.22.04.3BSD-2-clause, BSD-3-clause, LGPL-2.1, LGPL-2.1+~OpenSSL, public-domain
libssl33.1.4-r5Apache-2.0
libssl33.0.2-0ubuntu1.15Apache-2.0, Artistic, GPL-1, GPL-1+
libstdc++612.3.0-1ubuntu1~22.04Artistic, GFDL-1.2, GPL, GPL-2, GPL-3, LGPL
libsystemd0249.11-0ubuntu3.12CC0-1.0, Expat, GPL-2, GPL-2+, LGPL-2.1, LGPL-2.1+, public-domain
libtasn1-64.18.0-4build1GFDL-1.3, GPL-3, LGPL, LGPL-2.1
libtinfo66.3-2ubuntu0.1BSD-3-clause, MIT/X11, X11
libtirpc31.3.2-2ubuntu0.1BSD-3-Clause, GPL-2, LGPL-2.1
libtirpc-common1.3.2-2ubuntu0.1BSD-3-Clause, GPL-2, LGPL-2.1
libucontext1.2-r2ISC
libudev1249.11-0ubuntu3.12CC0-1.0, Expat, GPL-2, GPL-2+, LGPL-2.1, LGPL-2.1+, public-domain
libunistring1.1-r2GPL-2.0-or-later OR LGPL-3.0-or-later
libunistring21.0-1FreeSoftware, GFDL-1.2, GFDL-1.2+, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL-3, LGPL-3+, MIT
libuuid12.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
libxxhash00.8.1-1BSD-2-clause, GPL-2
libzstd11.4.8+dfsg-3build1BSD-3-clause, Expat, GPL-2, zlib
login1:4.8.1-2ubuntu2.2GPL-2
logsave1.46.5-2ubuntu1.1GPL-2, LGPL-2
lsb-base11.1.0ubuntu4BSD-3-clause, GPL-2
mawk1.3.4.20200120-3GPL-2
mount2.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
musl1.2.4_git20230717-r4MIT
musl1.2.2-4BSD-2-clause, BSD-3-clause, ISC, MIT, permissive, public-domain
musl-obstack1.2.3-r2GPL-2.0-or-later
musl-utils1.2.4_git20230717-r4MIT AND BSD-2-Clause AND GPL-2.0-or-later
ncurses-base6.3-2ubuntu0.1BSD-3-clause, MIT/X11, X11
ncurses-bin6.3-2ubuntu0.1BSD-3-clause, MIT/X11, X11
ncurses-terminfo-base6.4_p20231125-r0X11
nghttp2-libs1.58.0-r0MIT
openssl3.0.2-0ubuntu1.16Apache-2.0, Artistic, GPL-1, GPL-1+
passwd1:4.8.1-2ubuntu2.2GPL-2
perl-base5.34.0-3ubuntu1.3Artistic, Artistic-2, Artistic-dist, BSD-3-clause, BSD-3-clause-GENERIC, BSD-3-clause-with-weird-numbering, BSD-4-clause-POWERDOG, BZIP, DONT-CHANGE-THE-GPL, Expat, GPL-1, GPL-1+, GPL-2, GPL-2+, GPL-3+-WITH-BISON-EXCEPTION, HSIEH-BSD, HSIEH-DERIVATIVE, LGPL-2.1, REGCOMP, REGCOMP,, RRA-KEEP-THIS-NOTICE, SDBM-PUBLIC-DOMAIN, TEXT-TABS, Unicode, ZLIB
procps2:3.3.17-6ubuntu2.1GPL-2, GPL-2.0+, LGPL-2, LGPL-2.0+, LGPL-2.1, LGPL-2.1+
publicsuffix20211207.1025-1CC0, MPL-2.0
readline8.2.1-r2GPL-2.0-or-later
scanelf1.3.7-r2GPL-2.0-only
sed4.8-1ubuntu2GPL-3
sensible-utils0.0.17All-permissive, GPL-2, GPL-2+, configure, installsh
ssl_client1.36.1-r15GPL-2.0-only
sysvinit-utils3.01-1ubuntu1GPL-2, GPL-2+
tar1.34+dfsg-1ubuntu0.1.22.04.2GPL-2, GPL-3
tzdata2024a-r0Public-Domain
tzdata2024a-0ubuntu0.22.04ICU
ubuntu-keyring2021.03.26GPL
usrmerge25ubuntu2GPL, GPL-2
util-linux2.37.2-4ubuntu3.4BSD-2-clause, BSD-3-clause, BSD-4-clause, GPL-2, GPL-2+, GPL-3, GPL-3+, LGPL, LGPL-2, LGPL-2+, LGPL-2.1, LGPL-2.1+, LGPL-3, LGPL-3+, MIT, public-domain
zlib1.3.1-r0Zlib
zlib1g1:1.2.11.dfsg-2ubuntu9.2Zlib